Pioneer Systems

Incident Report for Connex

Resolved

This incident has been resolved by Microsoft. All systems are normal.
Posted Oct 29, 2025 - 19:00 CDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 29, 2025 - 14:45 CDT

Update

Due to a Microsoft service issue, Connex Approval Tool, Agency Management, PowerBI, and CorBiz users may experience intermittent errors. Microsoft is working on this and we are monitoring the situation.
Posted Oct 29, 2025 - 14:43 CDT

Identified

Microsoft has identified a plan to fix.
Posted Oct 29, 2025 - 14:40 CDT

Investigating

Due to a Microsoft service issue, Connex Approval Tool, Agency Management, PowerBI, and CorBiz users may experience intermittent errors. Microsoft is working on this and we are monitoring the situation.
Posted Oct 29, 2025 - 12:09 CDT
This incident affected: Connex, Approval Tool and CorBiz Mobile.