US check scanning currently unavailable

Incident Report for Connex

Resolved

This incident has been resolved.
Posted Jun 08, 2025 - 08:35 CDT

Investigating

Check scanning for US cash payments has been interrupted due to some maintenance. This began this morning (June 7) around 6:30 am CDT. We are working to restore this functionality. All other Connex functionality should be unaffected.
Posted Jun 07, 2025 - 19:58 CDT
This incident affected: Connex, Approval Tool.